"Namespace prefix xsl used but not declared" in included stylesheet

Subject: "Namespace prefix xsl used but not declared" in included stylesheet
From: "Igor Nakshin" <inakshin@xxxxxxxxxxx>
Date: Wed, 8 Mar 2000 18:02:30 -0600
Hello all,

I am getting a following error when transforming from XML to HTML using
latest Xalan
or Oracle processors :

oracle.xml.parser.v2.XSLException: XSL-1002: Error while processing include
webcv-document.xsl<Line 2, Column 38>: XML-0129: (Error) Namespace prefix
used but not declared.).

My root stylesheet is composed of a bunch of other stylesheets that are
imported using
xsl:include. None of the included stylesheets have <xsl:stylesheet ...> tag
in them, only
the root stylesheet.

The root stylesheet looks like:

<?xml version="1.0"?>
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform";
<xsl:output method="html" omit-xml-declaration="yes" indent="yes"

<!-- root template for the document -->
<xsl:template match="/">

<!-- include the standard templates -->
<xsl:include href="common/webcv-document.xsl"/>
<!-- more included stylesheets... -->

If I use the <xsl:stylesheet ..> tag in the included ones I get a different
error, that <xsl:stylesheet
tag must only appear once.

This used to work with Lotus XSL 0.19, but does not work in current, 0.20.
Tried with Oracle
XSL and getting the same result.

Am I missing something?

Any help is greatly appreciated.


Igor Nakshin

 XSL-List info and archive:  http://www.mulberrytech.com/xsl/xsl-list

Current Thread