RE: [xsl] Instant Saxon and JVM/Class path

Subject: RE: [xsl] Instant Saxon and JVM/Class path
From: "Michael Kay" <mike@xxxxxxxxxxxx>
Date: Fri, 28 Jan 2005 08:50:20 -0000
Instant Saxon was shipped in the days when Microsoft supplied a Java VM as
part of the operating system - the idea was that you could run it "out of
the box" without installing anything else. Sadly, Microsoft's initial
enthusiasm for Java waned and you now have to install Java yourself. If
you're using Windows XP then it's best to install Sun JDK 1.5 and use the
"full Saxon" product rather than using "Instant Saxon", which only works
with the old Microsoft JVM.

(I thought this was made pretty clear in the documentation....)

Michael Kay

> -----Original Message-----
> From: Gerrit Kuilder [mailto:gerrit@xxxxxxxxxxx]
> Sent: 28 January 2005 07:36
> To: xsl-list@xxxxxxxxxxxxxxxxxxxxxx
> Subject: [xsl] Instant Saxon and JVM/Class path
> Hi All,
> hopefully someone can help me with this,
> I have the following problem with the instant saxon 6.5.3
> when run from
> certain machines:
> E:\instant_saxon6_5_3>saxon Unable to start the application.  The
> Microsoft virtual machine cannot be found  Class not registered
> on other systems (one  has been around for a few years another is a
> pretty clean install) it runs without problems. I have googled a bit
> without any luck so any help would be appreciated.
> I have the Sun JRE/SDK  installed on the not working systems
> and on one
> of them I even have tomcat running.
> Any help will be appreciated
> Regards,
> Gerrit Kuilder, who apologizes for taking uo the bandwith...
> --
> Jeg holder peskeferie hele ugen.
> Med venlig hilsen
> Gerrit Kuilder

Current Thread