[xsl] problem with substring()

Subject: [xsl] problem with substring()
From: Rahil <qamar_rahil@xxxxxxxxxxx>
Date: Wed, 27 Apr 2005 13:03:41 +0100

I cant understand what Ive done wrong with my code that I aint getting any output.

<xsl:variable name="Val" select="text()"/>
<testVar><xsl:value-of select="$Val"/></testVar> <!--Prints the output 'hello there'-->

<xsl:variable name="firstVal" select="substring-before($Val,' ')"/> <!--empty result instead of 'hello'-->
<xsl:variable name="secondVal" select="substring-after($Val,' ')"/> <!--empty result instead of 'there'-->

Ive tried using another delimiter such 'a' in the substring() method and that works but not a space. Ive been regularly using this criteria in my other files and Ive had no problem. I even tried typeasting text() and Val to type string() but that dint work either. The problem seems to be in the space delimiter.

Ive tried everything I could to check why it isnt working but cant figure it out.

Could someone please help.


Current Thread