Problem with Docbook style sheets

Subject: Problem with Docbook style sheets
From: "Didier PH Martin" <martind@xxxxxxxxxxxxx>
Date: Thu, 28 Jan 1999 21:02:02 -0500

I tried to render the mulberry sgml cookbook doc and procedure sgml doc with
the latest docbook style from Norman's site. I discovered that the SGMLKit
catalog is incomplete. The file iso-amso.ent is missing in the current
installation package. The next release will correct that. You have just to
copy that file in the catalog directory.

I got a problem with the sgml output. First it worked perfectly well when I
set the output type to rtf but I did got nothing when I set the output type
to sgml.

Here is the entry I set in the Scripts file that worked very well for all
Mulberry sgm docs.
COMMAND <DOCTYPE="-//Davenport//DTD DocBook V3.0//EN"> <script = dsssl -t
rtf -o $DOCVIEW -d "$SCRIPT_DIR/DocBook/print/DocBook.dsl" >

I got the any documents located anywhere in my system displayed properly. I
installed the docbook directory under the Scripts directory. So any document
having the following prolog displayed OK (and I took the occasion to learn
something - thanks to people who wrote this)
<!DOCTYPE Book PUBLIC "-//Davenport//DTD DocBook V3.0//EN" .....other stuff

However when I changed the SCRIPTS file entry to:
COMMAND <DOCTYPE="-//Davenport//DTD DocBook V3.0//EN"> <script = dsssl -t
sgml -o $DOCVIEW -d "$SCRIPT_DIR/DocBook/html/DocBook.dsl" >

here is what I got (I didn't got any error message during the
<META content="text/html; charset=windows-1252"

Did anybody got problems to transform docbooks into HTML with the latest

Didier PH Martin

 DSSSList info and archive:

Current Thread