Re: How do I skip an element?

Subject: Re: How do I skip an element?
From: "Larry Mason" <Larry_Mason@xxxxxx>
Date: Wed, 5 May 1999 09:17:04 -0500

>> Here are some things I've tried to get the TH to work but are returning
>> token' or 'unexpected token' errors.
>> I don't know what the column names will be except there is one column that is
>> always present which I want to exclude.
>> <xsl:for-each select="data/*[first-of-any()]/*[name(.) !='column2']">
>>    <TH><xsl:value-of select="name(.)"/></TH>
>> </xsl:for-each>
>> <xsl:for-each select="data/*[first-of-any()]/* $and$ data/*/*[name(.)
>> !='column2']">
>>    <TH><xsl:value-of select="name(.)"/></TH>
>> </xsl:for-each>
>You're using non-standard Microsoft extensions, which of course XT doesn't
support. For
>reference about what XT supports, look at the official XSL spec--either
December or April
>depending on which version of XT. The key things you need to avoid in these
>cases are "!=" and "$and$".

Thanks to all who have replied and sorry for mixing MicroSoft extensions into my
example.  When I'm trying various solutions to resolve the problem, I look for
examples everywhere !

I am using the older version of XT for which none of the suggestions worked. :(
So I downloaded the latest XT Windows binary.  It accepts my improved XSL using
qname instead of name, [1] instead of first-of-any, etc but produces an error as

java.lang.NoSuchMethodError: com/jclark/xsl/tr/SheetImpl$ProcessContextImpl:

not found

This is NOT launched as java ... but rather as xt my.xml my.xsl.  I have placed
the latest xt.jar file in the same directory as xt.exe hoping
it would help.  It didn't.

If anyone has seen this, please let me know what I've done wrong.  The older XT
runs great.  I'm guessing it is an operator error!
Many thanks,
Larry Mason
i2 Technologies

 XSL-List info and archive:

Current Thread