Re: [xsl] xsl:import

Subject: Re: [xsl] xsl:import
From: "Michael Kay mike@xxxxxxxxxxxx" <xsl-list-service@xxxxxxxxxxxxxxxxxxxxxx>
Date: Sun, 23 Jul 2017 13:45:53 -0000
We dropped the warning in, see

But yes, Saxon-HE no longer supports 1.0 compatibility mode, and therefore
gives you an error if your stylesheet says version="1.0". We're trying to
encourage users to eliminate any dependencies on 1.0-mode - it's been 10 years

Michael Kay

> On 23 Jul 2017, at 14:37, Martin Honnen martin.honnen@xxxxxx
<xsl-list-service@xxxxxxxxxxxxxxxxxxxxxx> wrote:
> On 23.07.2017 15:26, Dave Pawson dave.pawson@xxxxxxxxx wrote:
>> That's running 1.0 stylesheets with 2.0 processor?
> Saxon 9.8 HE is an XSLT 3.0 processor and does what I said, it refuses to
run version="1.0" code but only emits a warning when running version="2.0"
> >> Saxon 9.8 HE does tell you with version="1.0" stylesheets that it does
> >> run them, you need at least version="2.0" in which case it emits a
>> What of running 2.0 stylesheet with 3.0 processor Martin?
> With Saxon 9.8 you get a warning, see

Current Thread