[stella] struggling with vcs.h...

Subject: [stella] struggling with vcs.h...
From: Manuel Polik <cybergoth@xxxxxxxx>
Date: Sun, 11 May 2003 23:59:36 +0200
Hi there!

After this almost turned me into a nervous wreck, I 
thought it's better to save others the trouble and tell 
you about my discoveries.

Well, it started harmless. I just wanted to use Glenns 
asymetric PF template once more for some experiments 
with PF graphics, when I found, that I was not able to 
properly compile it anymore by any means.

First I suspected the new DASM, but quickly found that 
the old one produced the same result, a zero length 

So, I tried this and that, analyzing all DASM output, 
checking all symbols *manually*, trying this, trying 

Well, finally after almost an hour, I found what causes 
the troubles: ->Segments<-

Well, so the new vcs.h starts defining segments.

Once you start using segments, it seems like it is a 
must to use segments for everything - and most of the 
old sources simply don't do that, because they aren't 
segmented at all.

Well, I'm not sure wether the segments are required in 
VCS.H or not or wether DASM should probably handle this, 
but I found an easy fix:

Just adding an additional segment like 
    SEG     Bank0
at the very end of VCS.h, seems to do the trick.

Then according to my experiments, both unsegmented and 
segmented sources seem to compile fine.

I'm not sure, wether this is the ultimate solution 
though. Maybe Andrew can further investigate...


Archives (includes files) at http://www.biglist.com/lists/stella/archives/
Unsub & more at http://www.biglist.com/lists/stella/

Current Thread