Re: [xsl] Document() and &

Subject: Re: [xsl] Document() and &
From: "B. Tommie Usdin" <btusdin@xxxxxxxxxxxxxxxx>
Date: Thu, 16 May 2002 15:08:26 -0400
>Date: Wed, 15 May 2002 15:06:06 +0200
>Subject: Re: [xsl] Document() and &amp;
>Cc: Jeni Tennison <jeni@xxxxxxxxxxxxxxxx>
>To: xsl-list@xxxxxxxxxxxxxxxxxxxxxx
>From: Josh Beach <josh.beach@xxxxxxxxxxx>
>Hello again,
>So I have switched to the Java Xalan processor and have the same error.
>I posted some incorrect information before. If I do the following I DO
>get the error.
>Earlier I stated that I this worked but it doesn't. With Xalan the error
>is stated like this "file:///Volumes/SharedDocs/TestFile.XSL; Line 129;
>Column 134; Can not load requested doc: Attribute name "TD" must be
>followed by the ' = ' character."
>So I'm not sure what to do here. I need to get the XML document from
>that server with that URI formation. Maybe someone has a alternative
>approach that I could attempt?
>Any suggestions would be greatly appreciated.
>Best regards,
>Josh Beach
>>> So on to my problem... what I need is for the reference to
>>> contain an ampersand. ie.
>>> <xsl:apply-templates
>>> select="document(';
>>> amp;id=12345')"/>
>>> This will not work and gives the following error "Error while
>>> parsing
>>> ''.
>>> Missing equals sign between attribute and attribute value". Some
>>> where along the line the ampersand gets removed. I have also tried
>>> using just a '&' instead of a '&amp;' (even thought I know that it
>>> is improper to do so) and get the same error.
>> The behaviour you're describing sounds very weird. What processor are
>> you using, and how are you invoking it? Using &amp; as you are doing
>> should work fine -- it certainly shouldn't get removed.

 XSL-List info and archive:

Current Thread