[xsl] commandline param's passing problem using saxon

Subject: [xsl] commandline param's passing problem using saxon
From: Karl <call14@xxxxxxxxx>
Date: Mon, 7 Aug 2006 15:33:40 +0100 (BST)

I have problem passing commandline param's to my xsl stylesheet using
saxon. I did tried all suggested param=value in with & without
dbl/single quotes (like "param=value" or param="value" or
param='value'). But no use.

Not sure whether someother mistake i make. The preview.xsl code is
(scaled down version)

<xsl:stylesheet version="1.0"
	<xsl:template match="/"> 
		<xsl:param name="contentType"/>
		<xsl:param name="contentIdentifier"/>
		<div id="content">
		   <xsl:value-of select="$contentType"/> - <xsl:value-of

and my cmd line call is:
java -jar saxon8.jar -t XMLfilename.xml preview.xsl
contentType=Topics contentIdentifier=Introduction >a.html 

These two are not picked up and displayed. 	

Is using <xsl:template match="/"> correct?

When i tried with <xsl:template match="preview"> or <xsl:template
name="preview">, my whole xml source get rendered? Any idea why?

What Am i missing? 

Also, later I will have to invoke the same cmd from a php file. So,
any other specific changes i should take care?

Thanks in adv

Inbox full of spam? Get leading spam protection and 1GB storage with All New Yahoo! Mail. http://uk.docs.yahoo.com/nowyoucan.html

Current Thread