Page x of 000

Subject: Page x of 000
From: Rachael Sokolowski <rsokolowski@xxxxxxxxxx>
Date: Wed, 09 Sep 1998 18:39:00 +0100

I have started working with DSSSL and am experiencing a  similar problem
that was  posted to the DSSSL listserv in April by David Pawson. I am
grateful for David's off-line suggestions but I am still stumped.

I am trying to print "Page x of y" in the footer of an RTF document.

The page number appears, but always set to 000 when I use
(current-node-page-number-sosofo). I tried the reformatting in Word as
posted some time ago (normal mode, ctrl-a, page layout) but the total number
of pages still does not appear. For me, this is not an option because I
would like to use WordViewer, and not Word and WordViewer does not permit
this sequence.

In looking at the RTF output itself, it is not referencing the variable for
the total number of pages. I'm afraid I'm either not getting the dsssl
syntax quite right or this can't be done. I based this following code from
some "table of contents" examples.

I know that my element SIG is the last element of the document and will be
on the last page:
and I define the footer in this way:
         (make sequence
          font-size:     HeadFootFontSize
          line-spacing:  HeadFootLineSpacing
          font-weight: 'bold
          (literal  "Page ")
          (literal " of ")
          (process-element-with-id "SIG")

I also tried one of David's suggestions:
changing the process-element-with-id
(with-mode xxx (process-element-with-id

then in the mode statement, use the current-node-page-number-sosofo. 

Alas, this also  did not  work. Any suggestions? 


Rachael Sokolowski
Chief Scientist and Vice President of Research
Co-chair, HL7 SGML/XML SIG
8 Central St
Arlington MA 02474
VOICE: 781 646 8877
FAX:   781 646 5377
PAGER: 800 436 4768 

 DSSSList info and archive:

Current Thread
  • Page x of 000
    • Rachael Sokolowski - from mail1.ability.netby (8.8.5/8.6.12) with ESMTP id SAA14175Wed, 9 Sep 1998 18:38:58 -0400 (EDT) <=