Re: Entity files for Jade/DocBook?

Subject: Re: Entity files for Jade/DocBook?
From: Tony Graham <tgraham@xxxxxxxxxxxxxxxx>
Date: Wed, 6 Jan 1999 15:14:39 -0500 (EST)
At 6 Jan 1999 08:12 -0800, Wroth, Mark wrote:
 > 	I am now sort of persuaded that my problems are largely related
 > to the MS Word installation (as opposed to Word itself).  The entity
 > &#945; (supposed to be alpha), as was the (DocBook defined, which I
 > think really means ISO-defined) entity &alpha; was appearing as "aacute"

Yes, it does mean ISO-defined.

 > in both the math flow objects and in ordinary running text.
 > Interestingly, the character was in the "Symbol Greek" font, which does
 > not exist in my system, and that seems to be the root of my problem.  

That comes from Jade doing the right thing, not necessarily the most
useful thing for displaying Greek symbols.  If you have multilingual
support installed, you should be able to change the font to "Arial
Greek" and have it display as an alpha.

However, if you're like me and you think that &alpha; should look
different from &agr;, e.g. by using "Symbol" font for &alpha; and the
current font for &agr;, then you're out of luck.

Jade is outputting Unicode character numbers, but not every font is
Unicode-compatible.  I had a problem once where &omega; was used in
some text set in Sabon, and I had to manually change the character in
the RTF from whatever it was in "Sabon Greek" (which doesn't exist to
the best of my knowledge) to the correct character in the "Symbol"

 > 	Unfortunately, mapping that font to "Symbol" results in
 > displaying a "(" (I think -- the glyph is not unambiguous). Manually
 > changing the character to an "a" (highlighting it and pressing the "a"
 > key) causes it to display an alpha.  It also results in following text
 > displaying in Greek (up to some point which looks arbitrary to me, but
 > is probably related to RTF grouping).

Or to the extent of the flow objects in your flow object tree.

 > 	At this point I downloaded the MS Word 97 viewer, which does a
 > better job (with -trtf as opposed to -trtf-95 which I had been using).
 > It still displays "alpha" as an "a, in a different font, but it displays
 > "sigma" and "lambda" as sigma and lambda, so I suspect this is the
 > design of the alpha in whatever font is being used.

I don't know.

 > 	While I still haven't solved my problem, I'm beginning to think
 > this conversation doesn't belong on this list, as I am now playing games
 > with Word as opposed to DSSSL or even SGML.  So I'd like to say thank
 > you to everyone; I don't intend to follow-up after this posting unless
 > the group decides that the issues involved with Word are germane.

It seems like a Jade-meets-Word problem to me, plus it's something
that several of us could appreciate being solved.


Tony Graham
Tony Graham                            mailto:tgraham@xxxxxxxxxxxxxxxx
Mulberry Technologies, Inc.      
17 West Jefferson Street                    Direct Phone: 301/315-9632
Suite 207                                          Phone: 301/315-9631
Rockville, MD  20850                                 Fax: 301/315-8285
  Mulberry Technologies: A Consultancy Specializing in SGML and XML

 DSSSList info and archive:

Current Thread