Re: OpenJade 1.3pre won't compile

Subject: Re: OpenJade 1.3pre won't compile
From: Jon Haugsand <Jon.Haugsand@xxxxx>
Date: 10 Nov 1999 09:43:58 +0100
* cav@xxxxxxxxxxxxxx
> Jon Haugsand wrote:
> > CharsetInfo.cxx:138: Internal compiler error.
> > CharsetInfo.cxx:138: Please submit a full bug report to
> `bug-g++@xxxxxxxxxxxxxxx'.
> > make[2]: *** [CharsetInfo.lo] Error 1
> I think if you disable compiler optimizations for that file, it will
> compile fine.
> I got that same error on the same file in a previous version of jade on
> solaris
> with gcc 2.8.1 and disabling optimizations solved the problem.

Maybe, but now that I finally managed to compile through the most of
it (with a newer compiler), I erred out with a strange bug.
The content of nsgmls/ is

LT_LIBS=../lib/ -lintl

The last item looks like a loader option. However, in Makefile.prog
there is the following line:


This causes the make job to abort with the error message "No rule for
target -lintl" -- naturally.

I actually removed this from Makefile.prog and the huge make job
finally managed to get to an end -- without any further error
messages. However, when I tried 'jade ...' the result was
"Segmentation fault"

:-( :-(

Has anyone actually managed to make binaries of this distribution?
If so, could the good guy step forward and give som step-by-step

Jon Haugsand
  Norwegian Computing Center, <> 
  <mailto:Jon.Haugsand@xxxxx>  Pho: +47 22852608 / +47 22852500, 
  Fax: +47 22697660, Pb 114 Blindern, N-0314 OSLO, Norway

 DSSSList info and archive:

Current Thread