RE: Jade

Subject: RE: Jade
From: "Dudley, Mark" <Mark.Dudley@xxxxxxxxxxxxx>
Date: Wed, 24 Nov 1999 08:48:19 -0500

I had this problem with one of the authors I was working with. As I
attempted to debug the problem I found that he was clicking on the jade.exe
icon from Explorer in Windows NT and attempting to run the command line from
the window that was displayed. As he did this he got the same error you are
receiving. The command lines were not meant to be run in this way.

To get around the error simply open a DOS window from your Start menu
(Start>Programs>Command Prompt or something like that) and navigate to the
directory your jade.exe is contained in using the standard DOS commands. You
can also run the jade executable from any directory as long as you give the
full relative or absolute path to is from any directory. Just know that it
has to be run from the DOS window instead of opening a window by double
clicking on jade.exe from Explorer or Program Manager.

No Windows voodoo...


-----Original Message-----
From: Peter Sognefur [mailto:sognefur@xxxxxxxxxxx]
Sent: Wednesday, November 24, 1999 5:29 AM
To: dssslist@xxxxxxxxxxxxxxxx
Subject: Jade


I use a simple xml document with a internal DTD subset. I just want to test 
Jade so I know that its working before I go on. The xml file and the dsssl 
style-sheet is a simple (I thought) example in a book that I'm reading. "XML

in 21 days".

This is the xml file:

<?xml version="1.0"?>

<!DOCTYPE test [
<!ELEMENT test (a|b)*>

<a>This is a test</a>
<b>This is also a test</b>
<b>This is another test</b>

And this is the dsssl file:

<!DOCTYPE style-sheet PUBLIC "-//James Clark//DTD DSSSL Style Sheet//EN">

(define *rgb-color-space*
	(color-space "ISO/IEC 10179:1996//Color-Space Family::Device RGB"))

(define *blue*
	(color *rgb-color-space* 0 0 1))

(define *red*
	(color *rgb-color-space* 1 0 0))

(root (make simple-page-sequence
	page width:    8.5in
	page-height:   11in
	top-margin:    1in
	bottom-margin: 1in
	left-margin:   1in
	right-margin:  1in
	    (process children)))

(element test
	(process children))

(element a
	(make paragraph
	 	font-size:	24pt
		color:		*blue*
		quadding:	'center
		space-before:	10pt
		line-spacing	20pt))

(element b
	(make paragraph
	 	font-size:	18pt
		color:		*red*
		line-spacing	30pt))

I cant find anything wrong....but I still got the same error message....

jade -f error.log -t rtf -wno-valid -d converter.dsl -o test.rtf test.xml
H:\Project\Software\Jade\jade.exe:<OSFD>0:1:0:E: carachter "j" not allowed 
in prolog

The "j" charachter is the first "j" in jade on the first row. I can write 
anything a

made -f error.log......

Then I will get this error message:

H:\Project\Software\Jade\jade.exe:<OSFD>0:1:0:E: carachter "m" not allowed 
in prolog




Get Your Private, Free Email at

 DSSSList info and archive:

 DSSSList info and archive:

Current Thread