strange behaviour with document()

Subject: strange behaviour with document()
From: Linda van den Brink <lvdbrink@xxxxxxx>
Date: Wed, 22 Nov 2000 12:35:57 +0100

I'm getting some strange behaviour, which seems entirely illogical to me,
when processing a list of files using the document() function. I'm using
Saxon 5.5.1 (full Java version). 

I have a system of XML index files and content files. I use the index files
as input for a stylesheet and then use the document function to transform
all the content files. 

I found out that the transformed result of one of the content files was
missing a section, that *was* there in the source file. I couldn't explain
this so I ran the transform again, but only on this one content file (which
saved me processing time). To my surprise the transformed file now *did*
have the section it missed before. I also tried moving the reference to this
content file to the end of the list of the index file, and then ran the
transform again on all the content files in the index file. And to my
surprise... the transformed content file in question did have the section it
missed before, and none of the other transformed files were missing

Can anyone explain this? 


 XSL-List info and archive:

Current Thread