[xsl] strange error in external dtd

Subject: [xsl] strange error in external dtd
From: Fred Christian <fredc@xxxxxxxxxx>
Date: Wed, 17 Dec 2008 17:16:14 -0800
I am using Saxon on 2 different Windows computers with different results
Both running Saxon 8.6.1 (I know, I should upgrade, sorry :(
And I have actually worked around the problem already but I can't help but be curious what might be going on.

I am not sure what the important difference is
On my XP computer my command line transform works fine.
On my Win 2000 Server computer, it fails with...

Error on line 239 column 15 of
SXXP0003: Error reported by XML parser: A colon is not allowed in the name 'IS10744:arch'
when namespaces are enabled.

Recoverable error on line 2467 of file:/C:/xslfiles/work.xsl:
FODC0005: org.xml.sax.SAXParseException: A colon is not allowed in the name 'IS10744:arch'
when namespaces are enabled.

Line 2467 of work.xsl is
<xsl:for-each select="document(string($psetDoc))" >
the doc being opened is an xhtml file with this doctype
<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.1 plus MathML 2.0//EN" "http://www.w3.org/TR/MathML2/dtd/xhtml-math11-f.dtd";>
<html xmlns="http://www.w3.org/1999/xhtml";>

I solved/worked around the problem by removing the doctype from my file. So far, I haven't found any side effects by doing so, but I wouldn't mind putting it back if I can.

Any guesses on what might be causing the error on my Win 2000 server computer and not the other?

Current Thread