Re: [xsl] bug in LibXSLT???

Subject: Re: [xsl] bug in LibXSLT???
From: Daniel Veillard <daniel@xxxxxxxxxxxx>
Date: Thu, 6 Mar 2003 10:09:51 +0100
On Wed, Mar 05, 2003 at 10:46:27PM -0500, S Woodside wrote:
> Hi there, I think I've uncovered a bug in LibXSLT. I have the following  
> versions installed of LibXSLT and sablotron.

  First if you have an identified bug for libsxlt this is not the
place to report it see for the

> In many places I print out the RNG path of the context node. That's the  
> path made up of the @name attributes of the ancestors of the context  
> node, in reverse document order. I have a simple template to do it  
> named "RNGPathToSelf". The problem is that in certain places I get the  
> wrong order ... it's not reverse or forward, it's half and half. See  
> for yourself ... :-\

  Well can you provide a concise example ? If this is an order problem
on one of the axis or something similar it's hard to tell from the full
example. I will look at it but provide first a simpler case if possible
or at least a preanalysis of the problem. Well maybe someone from the
list can help actually narrow down the problem.

> Here's the input, the XSLT, and the output from LibXSLT that's  
> incorrect marked with [[[BUG HERE]]], then the output from Sablotron  
> with the output marked [[[CORRECT HERE]]] . Apologies for the length of  
> the email, but the FAQ recommends providing full examples. I hope  
> someone will still help!


Daniel Veillard      | Red Hat Network
veillard@xxxxxxxxxx  | libxml Gnome XML XSLT toolkit | Rpmfind RPM search engine

 XSL-List info and archive:

Current Thread