Re: (dsssl) [OpenJade] Segfaults when running on a Solaris 2.6 machine

Subject: Re: (dsssl) [OpenJade] Segfaults when running on a Solaris 2.6 machine
From: Eric Brunel <eric_brunel@xxxxxxxx>
Date: Wed, 18 Apr 2001 22:10:07 +0200 (CEST)
Hi James,

> I am trying to use OpenJade to
> convert the XML to HTML but whenever I run it it
> segfaults and drops a
> core.
> I used the autoconf method to install OpenJade with
> gcc version 2.95.3
> and GNU make, the OS is Solaris 2.6.

I had this problem on Solaris when I tried to compile
a former version of OpenJade (which was only Jade at
that time) and finally figured out what happened: a
compilation with gcc apparently doesn't work on
Solaris 2.6. The symptoms were the same: the
compilation seemed to succeed, but whenever I ran jade
afterwards, it crashed with a core dump.
The only way I found to make it work was to compile
everything with the Sun C compiler. If you have it
installed, it's quite easy: just define the
environment variable "CC" to the full path of the Sun
compiler before running the "configure" script. The
compilation process should complete without problem
and your OpenJade shouldn't crash anymore.
If you don't have the Sun C compiler installed, it's
bad news, because according to what I heard, it isn't
exactly freeware, to say the least...

Hope this helps.
 - eric -

Do You Yahoo!? -- Pour dialoguer en direct avec vos amis, 
Yahoo! Messenger :

 DSSSList info and archive:

Current Thread