RE: [xsl] Fwd: Is this a Saxon Bug ?

Subject: RE: [xsl] Fwd: Is this a Saxon Bug ?
From: "Michael Kay" <mike@xxxxxxxxxxxx>
Date: Mon, 5 Oct 2009 22:58:42 +0100
Firstly, if you suspect a bug in a particular product, then this is not the
right place to report it. For Saxon, you should use the saxon-help mailing
list or forum on the SourceForge site. Using the right process enables the
vendor to track progress in responding to the bug, and it also ensures that
there is a proper archive that people can turn to for problems and
solutions. It also avoids wasting the time of the many members of this list
who use a different product.

Secondly, if you think there is something wrong then it is helpful to say
what it is. Not being able to read Braille, the only way I have found of
seeing what is in your files is to display them in hex, and it's very hard
to find a problem in the output when I don't know what I am looking for.

The fact that you are using XML 1.1 (and characters like #xC; that require
XML 1.1) may well have something to do with it. This would hint at a problem
with the XML parser, so it would be useful to say which XML parser you are
using, and also to indicate whether the problem disappears if you confine
yourself to XML 1.0. For any problem that is even potentially
parser-related, one of my first suggestions is always to make sure that you
are using the version of Xerces distributed by Apache, and not the version
that comes embedded in the Sun JDK, especially not the JDK 1.6 version,
which is notoriously buggy.


Michael Kay

> -----Original Message-----
> From: djidjoenator@xxxxxxxxx [mailto:djidjoenator@xxxxxxxxx]
> On Behalf Of Fridiric Schwebel
> Sent: 05 October 2009 19:19
> To: xsl-list
> Subject: [xsl] Fwd: Is this a Saxon Bug ?
> Hello, my problem is very simple though it seems to be unsolvable.
> Here's a source file and a stylesheet. In the sourcefile, all
> caracters are UTF8 (actually Braille characters). See my XSL sheet ?
> Could it be simpler ? I plan to do more things with it but there's a
> bug(?) already. This problem happens with some documents, I'm
> unable to find out what produces it.
> I ran the xsl sheet and this source document with the last
> SaxonB and the new SaxonHE, both results are the same. See
> the difference on lines 76-79 ? Does anyone know a workaround
> ? I tried to split the big text node, it still doesn't work.
> The 3 files (input output and xsl) are here :
> Thanks for any help,
> Regards
> Frederic Schwebel

Current Thread