RE: [stella] Space Instigators - Final Version (?)

Subject: RE: [stella] Space Instigators - Final Version (?)
From: Nicolás Olhaberry <nolh@xxxxxxxxxxxxx>
Date: Sun, 20 Oct 2002 07:13:37 -0300
----- Original Message -----
From: Christopher Tumber <christophertumber@xxxxxxxxxx>
To: <stella@xxxxxxxxxxx>
Sent: Saturday, October 19, 2002 10:27 PM
Subject: RE: [stella] Space Instigators - Final Version (?)

> Did you disassemble and go through it? Yikes! (but thanks!) if the source
code would be helpfull just let me know. I do plan to post it eventually but
at the moment it's basically uncommented (except where I wanted to remind
myself what the hell I'm doing...). However, if you're going to be going
through it anyway, the label names and formatting may make things a little
easier to read.

    I didn´t really disassembled it, just used the PCAE debugger (a great
debugging tool, by the way) to figure out why the screen wasn´t stable, I
didn´t even tried to understand what the code was doing. You should give it
a try, it´s very useful for game developers.

> Unfortunately I've been tinkering a little so things have move a bit -
enough anyway that I can't identify which WSYNC (There are a few...(smile)).
Can you tell me the lines directly preceeding or following that STA WYSYNC
you've mentioned above? Maybe I can add a NOP or two to the odd frames....

   Sure, I´ve used the latest bin. Here´s the Z26 log... a great logging
tool, by the way ;-)

f527: e6 9a    inc  9a
f529: a9 04    lda #04
f52b: 85 c7    sta  c7
f52d: a9 01    lda #01
f52f: 85 ca    sta  ca
f531: a9 00    lda #00
f535: 85 2b    sta  HMCLR
f537: 85 04    sta  NUSIZ0
f539: 85 05    sta  NUSIZ1
f53b: 85 1f    sta  ENABL
f53d: 85 82    sta  82
f53f: 85 ff    sta  ff
f541: a9 0c    lda #0c
f543: 85 06    sta  COLUP0
f545: 85 07    sta  COLUP1
f547: a5 c7    lda  c7
f549: 0a       asl  a
f54a: aa       tax

> [Just grabbed PCAE-DOS but can't seem to get it to run on my system

Have you tried to disable the sound before running the bin? Maybe that will
fix it.

> Maybe PCAE DOS more closely resembles the 7800? (Strange that Pcaewin
doesn't show this behaviour though...)

Looks like a bug to me. Probably it´s fixed in the version you´re using.



Archives (includes files) at
Unsub & more at

Current Thread