Re: (open)jade bug rendering LaTeX inside CDATA

Subject: Re: (open)jade bug rendering LaTeX inside CDATA
From: "Sebastian Rahtz" <sebastian.rahtz@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
Date: Sat, 20 May 2000 12:03:41 +0100 (BST)
Gary Lawrence Murphy writes:
 > I just tried a tests for other LaTeX-isms and there is no problem;
 > it is just the double dash so far as we have found.  Should be easy 
 > enough to fix once we find the stylesheet that handles it (it's
 > escaping the others ok)

I could have sworn someone had fixed this in OpenJade
 > which is clearly not what is wanted; it should also escape the dash. The
 > key is to find the escape of the slash as \char92{} and tuck in the
 > dash char code at that spot.

its not as easy as that. there is big case statement in jade which
looks character by character. the thing that does -- to endash is a
ligature in the font metric file...

looking at the source, has anyone tried adding "-" to this case
statement in Jade?

      case '\\':
      case '^':
      case '_':
      case '~':
        os() << "\\char" << int(*s) << "{}";


 DSSSList info and archive:

Current Thread