Re: [xsl] Cannot output CRLF

Subject: Re: [xsl] Cannot output CRLF
From: Owen Rees <owen.rees@xxxxxx>
Date: Wed, 03 May 2006 09:47:16 +0100
--On Tuesday, May 02, 2006 13:29:01 -0400 Paul Venuti wrote:

From all the posts I've seen on this list, this should work. But when I
the resulting file in hex, this is what I get:


48 65 6C 6C 6F 2E 0A

So that's H E L L O [LF]. What happened to the CR (0D)? I've tried this
with both Saxon 8.6.1 and Xalan 2.7.0 ... same results.

Running Saxon 8.7.1 from the command line ...

sh-3.00$ java -jar saxon8.jar -o text-out.txt textout.xslt textout.xslt
Warning: Running an XSLT 1.0 stylesheet with an XSLT 2.0 processor
sh-3.00$ od -t x1 text-out.txt
0000000 48 65 6c 6c 6f 2e 0d 0a
sh-3.00$ od -t c text-out.txt
0000000   H   e   l   l   o   .  \r  \n

textout.xslt contains the stylesheet cut and pasted from your message then edited to remove the spaces in the xsl:text element.

That output was cut/paste from a run on Linux but I got the same result on Windows XP.

How are you invoking your XSLT processor?

Owen Rees
Hewlett Packard Laboratories, Bristol, UK

Current Thread